home / blog

2026-11-04 · critical

CVE-2026-112917: Docker Desktop, AF_VSOCK isolation bypass

CVE-2026-112917: Container exposes Windows files in Docker Desktop; CVSS 9.2; patch 4.98.0+.

CVE-2026-112917: Docker Desktop, AF_VSOCK isolation bypass

CVE-2026-112917 affects Docker Desktop for Windows and targets the WSL2 backend on x86-64 architectures. An unprivileged Linux container can exploit 32-bit socketcall invocations to bypass seccomp restrictions on AF_VSOCK sockets, thereby gaining access to host-facing services and Windows files accessible to the logged-in user. LinuxKit-based backends are not affected by this vulnerability.

The CVSS score is 9.2 (Critical), indicating severe impact, though the officially declared severity has been labeled as 'medium' in available data—a discrepancy that administrators should watch for official clarifications. The vulnerability was published on NVD 2026-11-03 and is accompanied by a verified patch. Signals on X show 3 posts in the past 24 hours, reflecting community interest; however, some messages incorrectly describe the patch status.

Complete remediation requires simultaneous upgrade to Docker Desktop 4.98.0 (or later) and WSL 3.0.3 (or later). If Docker Desktop has been upgraded to 4.98.0+ but WSL remains older, the system remains vulnerable. IT teams should verify current versions of both components and coordinate updates. It is also recommended to audit the execution of containers whose origin is not certain, particularly in shared development environments.

At a glance

What
Bypass of AF_VSOCK seccomp restriction via 32-bit socketcall in unprivileged Linux container on Docker Desktop for Windows, x86-64 WSL2 version
Severity
CVSS 9.2 (Critical). Declared severity is 'medium' but the CVSS score contradicts this assessment. Impact includes access to Windows files and host-facing services.
Affected versions
Docker Desktop for Windows with WSL2 x86-64 backend; LinuxKit-based backends unaffected. Required patch: Docker Desktop 4.98.0 or later AND WSL 3.0.3 or later
Fix
Update to Docker Desktop 4.98.0 or later and WSL 3.0.3 or later. Docker Desktop 4.98.0+ on older WSL remains affected.
Status
Published on NVD 2026-11-03. Patch available.
Action
Verify current Docker Desktop and WSL versions. Plan simultaneous update of both components for full fix. Audit access to untrusted containers.

Sources: NVD, CVE-2026-112917

← All articles