home / blog
2026-11-06 · critical
CVE-2026-73098: Code Execution in Apache Juneau
CVE-2026-73098: Vulnerability in Apache Juneau enables class initialization, RCE risk. CVSS 10.0. Update to 9.2.1.

CVE-2026-73098 is an improper control of dynamically-loaded code vulnerability in Apache Juneau, a Java framework for data serialization and parsing. When Juneau parses a value into a property of type java.lang.Class, the class swap mechanism loads the named class with static initialization enabled. This means attacker-controlled input can name a class present in the application's classpath, causing execution of that class's static initializer without authorization, with impact depending on classes present in the deployment.
The CVSS score is 10.0, the maximum possible value, classified as critical. This vulnerability requires no authentication, is remotely exploitable, and enables arbitrary code execution. Social media signals indicate amplification over the last 24 hours (4 posts). The vulnerability was published on 2026-11-05 and the vendor released version 9.2.1 as a fix.
IT and CISO teams must immediately identify all services using Apache Juneau and verify their versions. Upgrading to 9.2.1 is the priority action. In parallel, examine the classpath of affected applications to identify classes with potentially dangerous static initializers. If immediate patching is not possible, deploy WAF with input validation rules and monitor parsing logs for exploitation attempts.
At a glance
- What
- Improper control of dynamically-loaded code in Apache Juneau during parsing of values into properties of type java.lang.Class. The class swap mechanism loads the named class with static initialization enabled, allowing execution of the static initializer of any class in the application's classpath through attacker-controlled input.
- Severity
- CVSS 10.0 (critical - maximum). Arbitrary code execution without authentication, remotely exploitable. Impact depends on classes present in the affected application's classpath.
- Affected versions
- Apache Juneau version 9.2.0 and earlier
- Fix
- Upgrade to Apache Juneau 9.2.1 or later
- Status
- Published on NVD 2026-11-05. Patch available. Social media signals indicate amplification (4 posts in last 24 hours, latest 2026-11-06).
- Action
- 1) Identify all Apache Juneau deployments in your organization and verify versions. 2) Update to 9.2.1 with highest priority. 3) Examine the classpath of affected applications to identify classes with potentially dangerous static initializers. 4) If immediate patching is not possible, deploy WAF rules or strict input validation. 5) Monitor parsing logs for exploitation attempts.
Sources: NVD, CVE-2026-73098