home / blog
2026-11-06 · high
CVE-2026-122192: Firecracker VMM Memory Compromise
Firecracker VMM: guest root reaches host memory. Versions 0.23.0-1.16.1 affected. Upgrade to 1.16.2 or 1.17.0+

CVE-2026-122192 affects Firecracker, the AWS hypervisor VMM (virtual machine monitor) used in cloud, serverless, and containerized environments. The flaw lies in improper handling of failed memory remap operations in versions 0.23.0 through 1.16.1. An attacker with root privileges inside a guest can exploit balloon or virtio-mem discard requests to read and modify the VMM host process memory when a microVM is restored from a snapshot with the File memory backend.
The vulnerability carries a CVSS score of 7.5 (high), confirmed in the official NVD record. The flaw has been remediated in versions 1.16.2 and 1.17.0 and later. Active discussion signals emerge on social media (4 posts in the last 24 hours with 8 interactions): security researchers explicitly flag the risk of guest root compromising VMM memory, underscoring the importance of timely patching.
Recommended actions are immediate: verify which Firecracker version runs in your cloud and containerized environments; deploy upgrades to 1.16.2 or 1.17.0+ across affected systems. For organizations unable to upgrade immediately, assess whether microVMs are restored from snapshots with File memory backend and whether workloads require guest root access, as all these specific conditions must be present for exploitation.
At a glance
- What
- Improper handling of failed memory remap in Firecracker VMM (versions 0.23.0-1.16.1) allows guest root to read and modify host process memory via balloon or virtio-mem discard requests on microVMs restored from snapshots with File memory backend
- Severity
- CVSS 7.5 (high)
- Affected versions
- Firecracker 0.23.0 through 1.16.1
- Fix
- Upgrade to Firecracker 1.16.2 or 1.17.0+
- Status
- CVE published on NVD November 4, 2026; patches available; active social media discussion
- Action
- Inventory Firecracker versions in cloud and container environments; prioritize upgrade to 1.16.2+ for systems with guest root access and File memory backend snapshots
Sources: NVD, CVE-2026-122192