home / blog
2026-10-29 · critical
CVE-2026-116692: Critical RCE in MLflow via custom scorers
Critical RCE in MLflow: scorer modules loaded without origin checks. Update to 3.17.0.

MLflow, the open source engineering platform for AI agents and machine learning models, is affected by vulnerability CVE-2026-116692. The issue concerns third-party scorer deserialization in mlflow/genai/scorers/base.py, which accepts any descendant of the allowed modules instead of requiring an exact match, enabling code execution via the /ajax-api/3.0/mlflow/scorer/invoke endpoint.
According to available data the vulnerability carries a CVSS score of 9.8, critical tier. It was published on NVD on October 27, 2026 and fixed in version 3.17.0. With authentication disabled, code execution requires no credentials; with basic auth, a principal able to create experiments and upload artifacts is required. In either case the allowed scorer package must be writable by the server. No reports of public exploit repositories appear in the data. Minimal social activity is recorded (4 posts, 7 interactions), a discussion signal not technically verified.
Teams running MLflow should update immediately to version 3.17.0 or later. It is important to verify that allowed scorer packages are not writable by the server process, review active authentication configurations, and restrict experiment creation and artifact upload permissions to trusted principals, also auditing publicly exposed artifact endpoints.
At a glance
- What
- Third-party scorer deserialization in MLflow accepts any descendant of the allowed modules instead of requiring an exact match, letting a caller load and execute a Python module of their choice via the /ajax-api/3.0/mlflow/scorer/invoke endpoint.
- Severity
- Critical, CVSS 9.8 according to available data.
- Affected versions
- From 3.12.0rc0 up to but excluding 3.17.0.
- Fix
- Fixed in version 3.17.0.
- Status
- Published on NVD on October 27, 2026; no public exploit repository signal reported in the data. Minimal social signals (4 posts in 24 hours, 7 interactions), not verified as technical facts.
- Action
- Update MLflow to version 3.17.0 or later; verify the allowed scorer package is not writable by the server process; review artifact endpoint permissions and the authentication mode in use.
Sources: NVD, CVE-2026-116692