home / blog
2026-11-08 · medium
CVE-2026-111967: Stored XSS in MP3 Audio Player plugin
Stored XSS in MP3 Audio Player plugin. Contributors inject JavaScript executed by admin. Update to version 5.16.

CVE-2026-111967 is a Stored XSS vulnerability in the WordPress MP3 Audio Player plugin (versions < 5.16). The plugin fails to properly escape the audio player shortcode attribute before inserting it into an HTML attribute, allowing users with Contributor-level access and above to inject arbitrary JavaScript. The injected code executes when another user, typically an administrator, views the content where the payload has been inserted.
The vulnerability is rated CVSS 6.8 (medium), but the potential impact is significant: since injected code executes in the administrator context, an attacker can create new admin accounts, steal session tokens, or modify the site. The CVE was published on 2026-10-28 by NVD. Public signals on GitHub (2026-11-08) document the existence of repositories claiming to contain proof-of-concept code for vulnerable versions up to 5.14. No confirmation of active wild exploitation has been reported.
Defenders must immediately update the MP3 Audio Player plugin to version 5.16 or later. In parallel, it is critical to audit posts and drafts created by Contributor-level users or higher since the CVE publication date (2026-10-28) to identify suspicious JavaScript in attributes. Where feasible, restrict Contributor permissions to users who genuinely require them to reduce the attack surface.
At a glance
- What
- Stored XSS vulnerability in WordPress MP3 Audio Player plugin versions < 5.16. Audio player shortcode attributes are not escaped before output, allowing arbitrary JavaScript injection that executes when administrators or other users view the content.
- Severity
- CVSS 6.8 (medium). However, the impact is potentially critical: injected code runs in administrator context, enabling admin account creation and credential theft.
- Affected versions
- MP3 Audio Player plugin: versions < 5.16. Public signals document vulnerability through version 5.14.
- Fix
- Update the plugin to version 5.16 or later. The patch is available since 2026-10-28 (CVE publication date).
- Status
- CVE published 2026-10-28. Public repositories on GitHub declare proof-of-concept availability for versions ≤ 5.14. No confirmation of active wild exploitation.
- Action
- 1) Identify plugin instances in use. 2) Update immediately to version 5.16+. 3) Review posts/drafts created by Contributor users for suspicious JavaScript. 4) Restrict Contributor permissions if not required.
Sources: NVD, CVE-2026-111967