home / blog
2026-11-01 · critical
CVE-2026-104019: OS Command Injection in Amazon SageMaker
Critical command injection flaw in SageMaker allows access to other users' credentials and commands.

CVE-2026-104019 is an OS command injection vulnerability in the startup validation script module of Amazon SageMaker Distribution, as used by Amazon SageMaker Unified Studio. The flaw allows an authenticated user with project contributor permissions to execute arbitrary commands in other project members' Studio Spaces via an unvalidated connection resource property that is interpolated into a shell invocation without neutralization. This leads to compromised confidentiality (access to other users' temporary role credentials) and integrity (modification of data and configurations).
The CVSS 9.0 (Critical) score reflects the lack of additional authentication required for exploitation and the direct impact on access to critical resources. The vulnerability was disclosed on October 2, 2026, and official patches are available from Amazon for all supported versions. Posts have been observed on X on November 1, 2026 in Japanese, consistent with the flaw description but containing no additional technical data; these signals document awareness spread among security professionals.
Administrators and CISOs managing SageMaker Unified Studio must: inventory SageMaker Distribution versions in use; update immediately to the corresponding patch versions (2.14.12, 3.9.12, 4.0.11, 4.1.11, 4.2.8, 4.3.5, 4.4.3 for their respective minor lines); for environments with unsupported minor lines, plan migration to supported versions before patches become unavailable; monitor access and execution logs to detect exploitation attempts or anomalous activity, particularly shell invocations from the startup validation context.
At a glance
- What
- OS command injection in the startup validation script of Amazon SageMaker Distribution, exploitable by authenticated users with project contributor permissions to execute arbitrary commands in other users' Spaces and access temporary role credentials.
- Severity
- CVSS 9.0 (Critical) - allows arbitrary command execution and theft of role credentials, with critical impact on confidentiality, integrity, and availability.
- Affected versions
- Amazon SageMaker Distribution 2.x < 2.14.12, 3.x < 3.9.12, 4.0.x < 4.0.11, 4.1.x < 4.1.11, 4.2.x < 4.2.8, 4.3.x < 4.3.5, 4.4.x < 4.4.3.
- Fix
- Update to specified patch versions (2.14.12, 3.9.12, 4.0.11, 4.1.11, 4.2.8, 4.3.5, 4.4.3). For unsupported minor lines, migrate to a supported version. In SageMaker Unified Studio, Spaces automatically adopt the latest patch on restart once patched images are deployed.
- Status
- Official patch available from Amazon since October 2, 2026.
- Action
- Verify SageMaker Distribution versions in use; update immediately to patch versions; monitor access logs for suspicious activity in Spaces.
Sources: NVD, CVE-2026-104019