home / blog

2026-10-30 · high

CVE-2025-14847: unauthorized memory read in MongoDB

Unauthorized memory read in MongoDB via Zlib headers. CVSS 7.5 high. Affects versions v3.6 to v8.2.

CVE-2025-14847: unauthorized memory read in MongoDB

CVE-2025-14847 is a vulnerability in the Zlib compression protocol used by MongoDB Server. Mismatched length fields in compressed protocol headers allow an unauthenticated client to read uninitialized heap memory, potentially exposing sensitive data stored in system buffers. The flaw affects every MongoDB version from v3.6 to v8.2, including the widely deployed Long-Term Support versions in production environments.

Severity is rated CVSS 7.5 (high) because no authentication is required: any network client can send malformed headers to read memory. Patch status is available for all versions: MongoDB released specific fixes (7.0.28, 8.0.17, 8.2.3, 6.0.27, 5.0.32, 4.4.30 and later). Signals on GitHub show publicly available triage tools to identify exposed instances, confirming that the CVE is known in security communities.

In defense, administrators must verify which MongoDB version is in production and apply the corresponding update from the official list. Since no authentication is required, all exposed instances on the network are at risk: isolating MongoDB behind strict firewall rules remains recommended until patches are applied. Publicly available triage tools can confirm exposure without introducing further risk beyond the CVE itself.

At a glance

What
Mismatched length fields in Zlib compressed protocol headers in MongoDB allow unauthorized read of uninitialized heap memory. CVE-2025-14847 affects unauthenticated clients.
Severity
High: CVSS 7.5
Affected versions
MongoDB Server v7.0 < 7.0.28; v8.0 < 8.0.17; v8.2 < 8.2.3; v6.0 < 6.0.27; v5.0 < 5.0.32; v4.4 < 4.4.30; v4.2 ≥ 4.2.0; v4.0 ≥ 4.0.0; v3.6 ≥ 3.6.0
Fix
Update to versions 7.0.28, 8.0.17, 8.2.3, 6.0.27, 5.0.32, 4.4.30 or later
Status
Patches available for all affected versions; triage tools publicly known on GitHub
Action
Verify MongoDB version in use; apply corresponding patch; verify exposure with triage tools; no authentication required for exploitation

Sources: NVD, CVE-2025-14847

← All articles