home / blog

2026-10-31 · high

CVE-2019-11043: Remote Code Execution in PHP FPM

CVE-2019-11043 enables RCE in PHP FPM (CVSS 8.7). Impacts versions 7.1, 7.2, 7.3. Recent activity detected.

CVE-2019-11043: Remote Code Execution in PHP FPM

CVE-2019-11043 is a buffer overflow vulnerability in the PHP-FPM module that, under certain configurations, allows writing past allocated buffers into FCGI protocol data space, enabling remote code execution (RCE). It impacts PHP installations running FPM as process manager, including shared hosting and mission-critical web applications.

The vulnerability scores CVSS 8.7 (high severity), confirmed by official NVD sources. Although discovered in 2019, recent signals (October 2026) of public discussion and dedicated toolkits for detection and remediation demonstrate it remains an active threat in unpatched infrastructure. No evidence of mass active exploitation is public, but ease of exploitation in vulnerable environments makes it a priority.

System administrators and DevOps teams must immediately verify PHP versions in production. If versions 7.1.x < 7.1.33, 7.2.x < 7.2.24, or 7.3.x < 7.3.11 with FPM enabled are in use, upgrading to patched versions is mandatory. Test in staging before production deployment, review FPM logs for attack signals (buffer overflow errors, worker crashes), monitor anomalous FCGI requests.

FPM (FastCGI Process Manager) is widely deployed in hosting providers, SaaS platforms, and containerized infrastructures. A 'standard' FPM configuration with certain buffer settings can be vulnerable unknowingly. Examining correction patterns in PHP.ini and FPM configuration can help identify whether the system has been properly patched or if deeper review is needed.

Visibility is critical: ensure FPM logs properly record crashes and worker errors. Use vulnerability scanning tools to audit PHP versions in use. Maintaining PHP at actively supported versions remains the recommended path for long-term security.

At a glance

What
Buffer overflow in PHP-FPM allowing writes past allocated limits into FCGI protocol space, enabling remote code execution (RCE) under specific FPM configurations.
Severity
CVSS 8.7 (high severity). Critical impact on system confidentiality and availability.
Affected versions
PHP 7.1.x < 7.1.33, PHP 7.2.x < 7.2.24, PHP 7.3.x < 7.3.11 with FPM enabled.
Fix
Upgrade to patched versions: PHP 7.1.33 or later, 7.2.24 or later, 7.3.11 or later. Test in staging before production deployment.
Status
CVE confirmed at NVD (2019-10-28). Recent public discussion and remediation toolkits (October 2026) confirm ongoing relevance.
Action
Verify PHP versions in production. Apply immediate patch if in vulnerable range. Monitor FPM logs for errors and anomalies. Restart FPM after patching.

Sources: NVD, CVE-2019-11043

← All articles