home / blog
2026-11-05 · critical
CVE-2017-18349: RCE in Fastjson via JSON crafted
Fastjson < 1.2.25 allows RCE through crafted JSON with rmi:// URI. CVSS 10.0 critical. Upgrade to 1.2.25+.

CVE-2017-18349 is a remote code execution (RCE) vulnerability in Fastjson before version 1.2.25. The flaw exists in the parseObject method which processes crafted JSON requests. Attackers exploit an rmi:// URI embedded in the dataSourceName field of an HTTP POST request to execute arbitrary code. The vulnerability affects Fastjson and products that bundle it, including FastjsonEngine in Pippo 1.11.0 and other software.
The CVSS score is 10.0, the maximum criticality level. The vulnerability was disclosed on NVD on October 23, 2018. As of November 2026, signals from GitHub repositories indicate the availability of environments and proofs of concept related to CVE-2017-18349. This is not confirmed active exploitation, but rather public signals about available research tools.
IT teams and administrators must identify all instances of Fastjson < 1.2.25 in production environments and upgrade to version 1.2.25 or later. If Pippo is in use, verify that the version number is greater than 1.11.0. Applying the official patch is the only effective mitigation; it is not advisable to download or execute exploits from public repositories. Monitor access logs to affected services to detect anomalous exploitation attempts.
At a glance
- What
- parseObject in Fastjson < 1.2.25 processes crafted JSON requests with rmi:// URI in the dataSourceName field, allowing arbitrary code execution via HTTP POST to the /json endpoint
- Severity
- CVSS 10.0 (maximum level, extreme criticality)
- Affected versions
- Fastjson before 1.2.25; FastjsonEngine in Pippo 1.11.0; other products bundling vulnerable Fastjson
- Fix
- Upgrade to Fastjson 1.2.25 or later; check updates for Pippo and dependent software
- Status
- Vulnerability disclosed on NVD on October 23, 2018; PoC and environment signals available on GitHub as of November 2026
- Action
- Identify Fastjson < 1.2.25 instances in production; upgrade to 1.2.25+; verify Pippo versions in use; monitor access logs for exploitation attempts; do not download exploits from public repositories
Sources: NVD, CVE-2017-18349